Back to overview
Degraded

Some services are down

Apr 01 at 01:09pm CEST
Affected services
E-mail

Resolved
Apr 01 at 01:13pm CEST

Our email server should be working properly again.

Created
Apr 01 at 01:09pm CEST

Our email server has connection issues.